Write the doc for sam3 examples.
[bertos.git] / boards / sam3x-ek / examples / sam3x-ek_http_server / .spec
1 name = 'Simple HTTP server'
2 description="""
3 <h2>Overview</h2>
4 <p>
5 This example application demonstrates the usage of the lwIP TCP/IP stack with
6 BeRTOS.
7 <\p>
8 <p>
9 The DHCP protocol is used to obtain an IP address from an external DHCP server
10 connected via ethernet.
11 <\p>
12 <p>
13 The server reply to the client request sending the page that match the file stored on SD
14 Card. If the SD or file is not preset, the server reply with header 404 FILE NOT found,
15 and send harcoded html page that report the occured error.
16 </p>
17 <p>
18 The BeRTOS simple HTTP server can reply the internal status or other things that the user wants, like: temperature,
19 local ip, etc, to do this the client can load special pages that match an harcoded callbacks, where it return to client
20 sending JSON string.
21 </p>
22 """