STM32-P103: add usbserial preset
[bertos.git] / boards / stm32-p103 / examples / usbserial / .spec
1 name = 'BeRTOS USB/Serial converter'
2 description="""
3 <h1>BeRTOS USB/Serial converter</h1>
4
5 <h2>Overview</h2>
6
7 <p>This example implements a real USB/serial converter using the <b><i>Olimex
8 STM32-P103</i></b> evaluation board. Two independent processes are created
9 exploiting the preemptive kernel. One process reads from the USB port and
10 writes to the UART port, the other does the opposite.</p>
11
12 <p>The project can be compiled and flashed to the STM32-P103. Then, the board
13 can be connected to any USB port of a standard PC and it will be recognized as
14 a generic USB/serial converter.</p>
15
16 <p>For example, on a Linux PC:</p>
17 <pre>
18 $ dmesg | tail
19 [18058.280545] usb 1-8.1.3: new full speed USB device using ehci_hcd and address 25
20 [18058.392775] usb 1-8.1.3: configuration #1 chosen from 1 choice
21 [18058.393118] usbserial_generic 1-8.1.3:1.0: generic converter detected
22 [18058.393332] usb 1-8.1.3: generic converter now attached to ttyUSB1
23 </pre>
24 """