name = 'TCP/IP echo server' description="""

Overview

This example application demonstrates the usage of the lwIP TCP/IP stack with BeRTOS. <\p>

The DHCP protocol is used to obtain an IP address from an external DHCP server connected via ethernet. <\p>

The application then starts a TCP server listening on port 80. The server acts as a TCP echo service, sending back to the clients all the submitted requests.

On the debugging console are reported the measured total requests and total requests per second (reqs/s) served by the TCP service, together with the stack usage of each process.

"""