name = 'BeRTOS USB/Serial converter' description="""

BeRTOS USB/Serial converter

Overview

This example implements a real USB/serial converter using the Olimex STM32-P103 evaluation board. Two independent processes are created exploiting the preemptive kernel. One process reads from the USB port and writes to the UART port, the other does the opposite.

The project can be compiled and flashed to the STM32-P103. Then, the board can be connected to any USB port of a standard PC and it will be recognized as a generic USB/serial converter.

For example, on a Linux PC:

$ dmesg | tail
[18058.280545] usb 1-8.1.3: new full speed USB device using ehci_hcd and address 25
[18058.392775] usb 1-8.1.3: configuration #1 chosen from 1 choice
[18058.393118] usbserial_generic 1-8.1.3:1.0: generic converter detected
[18058.393332] usb 1-8.1.3: generic converter now attached to ttyUSB1
"""