rpm: assign a real shell to user monkeysphere
[monkeysphere.git] / packaging / rpm / monkeysphere.spec
1 Name: monkeysphere
2 Summary: Use the OpenPGP web of trust to verify ssh connections
3 Version: 0.29
4 Release: 3
5 License: GPLv3+
6 Group: Applications/Internet
7 URL: http://web.monkeysphere.info/
8
9 Source: http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_%{version}.orig.tar.gz
10
11 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13 Requires: gnupg
14 Requires: openssh-clients
15
16
17 %description
18 SSH key-based authentication is tried-and-true, but it lacks a true
19 Public Key Infrastructure for key certification, revocation and
20 expiration.  Monkeysphere is a framework that uses the OpenPGP web of
21 trust for these PKI functions.  It can be used in both directions: for
22 users to get validated host keys, and for hosts to authenticate users.
23
24 %prep
25 %setup -q
26
27 %build
28 %{__make} %{?_smp_mflags}
29
30 %install
31 %{__rm} -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 mkdir -p %{buildroot}%{_var}/lib/monkeysphere
34
35 %clean
36 %{__rm} -rf %{buildroot}
37
38 %pre
39 groupadd -r %{name} &>/dev/null || :
40 useradd -r -g %{name} -d %{_var}/lib/%{name} -s /bin/bash \
41         -c "Monkeysphere authentication user" %{name} &>/dev/null || :
42 exit 0
43
44 %postun
45 test "$1" != 0 || userdel  %{name} &>/dev/null || :
46 test "$1" != 0 || groupdel %{name} &>/dev/null || :
47
48 %files
49 %defattr(-, root, root, 0755)
50
51 %dir %{_sysconfdir}/monkeysphere
52 %config(noreplace) %{_sysconfdir}/monkeysphere/monkeysphere-authentication.conf
53 %config(noreplace) %{_sysconfdir}/monkeysphere/monkeysphere-host.conf
54 %config(noreplace) %{_sysconfdir}/monkeysphere/monkeysphere.conf
55 %{_bindir}/monkeysphere
56 %{_bindir}/openpgp2ssh
57 %{_bindir}/pem2openpgp
58 %{_sbindir}/monkeysphere-authentication
59 %{_sbindir}/monkeysphere-host
60 %doc %dir %{_docdir}/monkeysphere
61 %doc %{_docdir}/monkeysphere/Changelog
62 %doc %{_docdir}/monkeysphere/MonkeySpec
63 %doc %{_docdir}/monkeysphere/TODO
64 %doc %{_docdir}/monkeysphere/getting-started-admin.mdwn
65 %doc %{_docdir}/monkeysphere/getting-started-user.mdwn
66 %doc %{_mandir}/man1/*
67 %doc %{_mandir}/man7/*
68 %doc %{_mandir}/man8/*
69 %doc %{_datadir}/monkeysphere/*
70 %dir %{_var}/lib/monkeysphere
71
72
73 %changelog
74 * Tue Mar 30 2010 Bernie Innocenti <bernie@codewiz.org> - 0.28-3
75 - Give a real shell to monkeysphere user.
76 - Simplify pre/postun macros.
77
78 * Tue Mar 30 2010 Bernie Innocenti <bernie@codewiz.org> - 0.28-2
79 - Create user monkeysphere on installation.
80
81 * Tue Mar 30 2010 Bernie Innocenti <bernie@codewiz.org> - 0.28-1
82 - Update to 0.28.
83 - Various fixes for Fedora.
84
85 * Sat Nov 22 2008 Anonymous Coward <anonymous@example.com> - 0.22
86 - Initial release.