Edit page MedicalRecords
[wiki.git] / UbuntuPaperCuts
index 1e3102b..518aa27 100644 (file)
-== Oneiric desktop paper cuts ==
+== Precise desktop paper cuts ==
 
 === Indicators ===
 
- # Where has the Displays idicator gone??
+ # The indicator icon for configuring the display resolution no longer exists
    * oneiric regression
    * confirmed on precise
+   * probably "by design", but... wtf
 
- # When the control panel is already open but hidden behind other windows or on a different virtual desktop, clicking on "Sound Settings" or "Bluetooth Settings" does not bring it to the foreground, thus confusing users.
+ # When the control panel is open but --hidden behind other windows or-- on a different virtual desktop, clicking on "Sound Settings" or "Bluetooth Settings" does not bring it to the foreground, thus confusing users.
    * oneiric regression
    * confirmed on precise
 
- # Why can't the desktop remember that I don't want mirrored displays when I connect my laptop to the docking station?
+ # --Why can't the desktop remember that I don't want mirrored displays when I connect my laptop to the docking station?--
+   * this bug actually can't be reproduced every time I plug in an external monitor. It's hard to tell if there's an underlying logic.
+   * FIXED in precise or maybe in quantal
 
- # oneiric regression: When I connect a DisplayPort monitor, sometimes the audio switches to it (but sometimes it doesn't, I couldn't figure out why). The output setting is buried deep into Control Panel / Sound Settings / Hardware / Profile, so it took me a while to figure out what had happened the first time.
+ # It looks like the HDMI audio output remains selected even when the output gets unplugged. As a result, the laptop does not play sound any more.
+ You can fix the problem by going to Sound Settings and click once on the internal audio output (which is the only output).
 
- # oneiric regression: Similar to previous bug: sometimes when I switch on the DisplayPort output I get no sound, no matter how I set the Profile in Sound Settings. The only way to make it work is turn off the external monitor and turn it on again.
+ # oneiric regression: Sometimes when I switch on the HDMI output, the sound also switches to it, but not consistently.
 
- # oneiric regression: no workspace previews in the panel. There's indicator-workspaces on Launchpad ([[https://launchpad.net/~geod/+archive/ppa-geod]]), but it doesn't start automatically at login.
+ # oneiric regression: We've lost the workspace previews in the panel. There's indicator-workspaces on Launchpad ([[https://launchpad.net/~geod/+archive/ppa-geod]]), but it only shows the current desktop number.
 
- # oneiric regression: Same for the system load indicator: it does not start automatically at login.
+ # --oneiric regression: The System Load indicator doesn't start automatically on login--
 
- # oneiric regression: Tray icons, including the bluetooth icon and the KTorrent icon, sometimes disappears from the panel. The icons can still be seen by opening the unity-2d-panel.
+ # --oneiric regression: Tray icons, including the bluetooth icon and the KTorrent icon, sometimes disappears from the panel. The icons can still be seen by opening the unity-2d-panel.--
+   * FIXED in Precise
 
- # menus of GTK3 applications appear in the window itself rather than in the Unity panel
+ # --menus of GTK3 applications appear in the window itself rather than in the Unity panel--
    * oneiric regression
    * FIXED in oneiric
 
+ # Displays: sometimes clicking on the second monitor does not select it. After fiddling with it long enough (dragging, clicking, etc) eventually it gets selected.
 
 === Window management ===
 
- # oneiric regression, fixed on precise: windows often open with the title bars hidden by the top panel and you can only drag them out with alt+click.
-
- # oneiric regression: dragging windows around becomes slow and jerky after some time. OpenGL acceleration works fine, it seems like a compiz issue with the intel driver. I can easily reprodiuce this on a Thinkpad X201 (Arrandale), but it's a lot harder to trigger on a X220 (Sandybridge).
-
- # oneiric regression: when I switch workspaces, sometimes focus goes to a window hidden behind another full-screen window. In general, compiz does not remember which window had focus in each workspace.
+ # --Dragging windows around becomes slow and jerky after some time. OpenGL acceleration works fine, it seems like a compiz issue with the intel driver. I can easily reprodiuce this on a Thinkpad X201 (Arrandale), but it's a lot harder to trigger on a X220 (Sandybridge).--
+   * oneiric regression
+   * [[https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/770160]]: windows start to move slow after using compiz for some hours
+   * [[https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/773861]]: Moving windows is very laggy with Compiz
+   * [[https://bugs.launchpad.net/ubuntu/+source/unity/+bug/803943]]: compiz consuming a lot of cpu
+   * [[https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/888039]]: Gradual degradation in desktop performance.
+   * [[https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/891744]]: Dragging windows stutter during and after grid animation
+   * Improved in Precise, but there's still high cpu usage in some cases (see bugs)
+   * FIXED in Quantal and maybe also in Precise
+
+ # --When switching workspaces, focus can go to a window hidden behind another full-screen window. Compiz does not seem to remember which window previously had focus in each workspace.--
+   * oneiric regression
+   * FIXED in Precise
 
- # long-time issue, confirmed on precise: When the video mode changes, full-screen windows often get shuffled on different workspaces and don't come back to their original locations when the resolution changes back. This is particularly annoying when plugging/unplugging monitors.
+ # When the video mode changes, full-screen windows get shuffled to different workspaces and don't come back to their original locations when the resolution changes back. This is particularly annoying when plugging/unplugging monitors.
+   * this is a longstanding issue with compiz
+   * confirmed on Precise
 
  # the "Desktop Cube" plugin of Compiz makes the display flicker briefly every time I switch workspace. This happens both with a Thinkpad X201 (Arrandale) and X200s (GM45).
    * oneiric regression
    * confirmed on precise
 
- # If I drag an icon around in Nautilus, I can often make Compiz hang. Restarting Unity from the console often cures the problem.
+ # --If I drag an icon around in Nautilus, I can often make Compiz hang after a while. Restarting Unity from the console often cures the problem.--
+   * FIXED in Precise
 
  # While dragging icons or other objects, I can only switch workspaces by going to the left edge. It doesn't work on the right. This happens with both "Desktop Wall" and "Desktop Cube".
+   * In precise, desktop switching works on both edges, but the screen flickers awfully
 
+ # You can't abort icon dragging with the ESC key
+   * Oneiric regression
+   * Confirmed on Precise
 
-=== Session management ===
+ # When dragging a window across the edge to another desktop, the mouse cursor jumps to the left or to the right, outside of the window title.--
+   * Confirmed on Precise
 
- # oneiric regression, confirmed on precise: There's no longer a way to save the X session? Before, it was working only for half of my applications, but it would still save some time after a reboot.
+=== Session management ===
 
- # oneiric regression: Switch User Account locks my current session and then it doesn't bring up the login screen. (I'm running gdm, not lightdm)
+ # There's no longer a way to save the X session? Before it was working only for some applications, but it was still a big time saver after a reboot.
+   * oneiric regression
+   * confirmed on precise
 
+ # --Switch User Account locks my current session and then doesn't bring up the login screen. (I'm running gdm, not lightdm)--
+   * oneiric regression
+   * works with lightdm
 
 === Unity Dock ===
 
- # oneiric regression, fixed in precise: the search bar often takes several seconds to show up when invoked with the keyboard.
+ # --The search bar often takes several seconds to show up when invoked with the keyboard--
+   * oneiric regression
+   * fixed in precise
 
- # There's a "Workspace Switcher" on the dock that doesn't do anything when I click on it. It's totally dead and I cannot even remove it. I have 4 virtual desktops and the Desktop Wall plugin is enabled.
+ # --There's a dead "Workspace Switcher" icon on the dock that doesn't do anything when I click on it and I cannot even remove it from the dock--
+   * It turns out that this icon works only if you enable Expo in compiz. Ok, but why can't I get rid of it??
+   * https://bugs.launchpad.net/ubuntu/+source/unity/+bug/921271
 
- # fixed in oneiric: There's also a trashcan icon on my dock that brings up a new tab in browser!
+ # --There's a trashcan icon on my dock that brings up a new tab in browser--
+   * fixed in oneiric
 
- # long-time issue, confirmed in precise: Notification OSDs won't go away by clicking on them. They just become more transparent when hovering the mouse. I can reproduce it every time by typing "notify-send foo" in a terminal.
+ # --Notification OSDs won't go away by clicking on them. They just become more transparent when hovering the mouse. I can reproduce it every time by typing "notify-send foo" in a terminal--
+   * long-time issue
+   * confirmed in precise
+   * NOTABUG: works this way by design :-(
+   * Workaround: uninstall notify-osd and install notification-daemon
 
- # fixed in oneiric: I can't configure the key to switch focus to the launcher to Super alone. I had to resort to Super-space, which is not comfortable for me.
+ # --I can't configure the key to switch focus to the launcher to Super alone. I had to resort to Super-space, which is not comfortable for me--
+   * fixed in oneiric
 
- # If I edit preferences in ccsm, sometimes Unity does not pick them up until I restart it.
+ # --If I edit preferences in ccsm, sometimes Unity does not pick them up until restarted--
+   * I haven't seen this in a while, it's probably fixed
 
+ # When I enable or disable a plugin in ccsm, sometimes compiz hangs. If I kill it, it takes down the whole X server
+   * See: http://people.sugarlabs.org/bernie/Xorg-crashed-on-compiz-close.0.log
+   * Confirmed on Precise
 
 === Applications ===
 
- # oneiric regression: The Gnome Control Center (aka System Settings) often closes when clicking on icons. I suspect it's simply crashing.
+ # --The Gnome Control Center (aka System Settings) often closes when clicking on icons. I suspect it's simply crashing.--
+   * oneiric regression
+   * Fixed in Precise
 
- # Evolution 3: the (webkit based) mail preview pane sometimes "crashes". It remains blank or garbled and there's no way to restore it until I restart the application.
+ # --Evolution 3: the (webkit based) mail preview pane sometimes "crashes". It remains blank or garbled and there's no way to restore it until I restart the application.--
+   * Fixed in Precise
 
- # Evolution 3: forgets my Google account password every time I start it. Works with other IMAP accounts.
+ # --Evolution 3: forgets my Google account password every time I start it. Works with other IMAP accounts.--
+   * Fixed in Precise
 
- # Evolution 3: my Google calendars no longer show up (no errors are displayed). The CalDAV calendars still work.
+ # --Evolution 3: my Google calendars no longer show up (no errors are displayed). The CalDAV calendars still work.--
+   * Fixed in Precise
 
- # Evolution 3: sometimes Evolution just stops polling for email until I restart it
+ # --Evolution 3: sometimes Evolution just stops polling for email until I restart it--
+   * Fixed in Precise
 
- # Evolution 3: sometimes Evolution hangs during shutdown until I kill it from the terminal
+ # Evolution 3: sometimes Evolution hangs on shutdown until I kill it from the terminal
 
- # Evolution 3: this might sound like a rant, but due to many other stability issues with Evolution, my email experience has become really miserable in Oneiric.
+ # --Evolution 3: this might sound like a rant, but due to many other stability issues with Evolution, my email experience has become really miserable in Oneiric.--
+   * Decent in Precise
 
 
 === Hardware support ===
 
- # Wifi becomes incredibly slow after a few minutes of use (like, 1-2kb/s). This is a an Intel iwlagn 6250. I tried all kernels all the way to 3.2 with no improvement. The only workaround I could find is disabling 802.11n support.
-   * Likely this bug: http://marc.info/?l=linux-kernel&m=131914553920614&w=2
+ # When I connect a monitor to the DisplayPort output, sometimes the sound output also switches to it (but sometimes it doesn't, I couldn't figure out why). The sound output setting is buried deep into Control Panel / Sound Settings / Hardware / Profile, so it took me a while to figure out what had happened the first time.
+   * oneiric regression
+
+ # HDMI/DisplayPort sound no longer works
+   * Probably this kernel 3.2 regression: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/973704
+   * Fixed in upstream kernel 3.4
 
- # My jWin bluetooth headphones stop working if I don't play anything for 30 seconds.  Afterwards, sound applications hang until I disconnect the bluetooth device.
+ # If I unplug AC while the lid is closed, the laptop does not automatically suspend. This is very dangerous because you can accidentally store your laptop in a backpack while it's still running.
+  * https://bugs.launchpad.net/ubuntu/+source/linux/+bug/886629
+
+ # --Wifi becomes incredibly slow after a few minutes of use (like, 1-2kb/s). This is a an Intel iwlagn 6250. I tried all kernels all the way to 3.2 with no improvement. The only workaround I could find is disabling 802.11n support.--
+   * Likely this bug: http://marc.info/?l=linux-kernel&m=131914553920614&w=2
+   * Fixed in precise
+ # --My jWin Bluetooth headphones stop working when there's no sound output for about 30 seconds.  After this, all applications that try to play some sound will hang until I disconnect the bluetooth device--
    * Fixed in kernel 3.2
 
  # The Bluetooth headphones don't get automatically reconnected when I turn them on.  Clicking on Connect in the control panel seems to work for one second, then it fails.  The only way to reconnect is removing the device and then paring it again.
    * https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/437649
    * confirmed on precise
 
- # Sometimes, when switching monitors on/off the DisplayPort output starts to flicker. Looks like a double-buffering issue.
+ # --Sometimes, when switching monitors on/off, the DisplayPort output starts to flicker. Looks very much like a double-buffering issue--
    * I've not seen this in a while, maybe fixed
 
 === Upgrade issues ===
 
- # Unbootable machine: after upgrading to Oneiric, the machine became unbootable due to an incomplete /run migration. There's a bug in Launchpad, but it's not getting any attention.
+ # --After upgrading to Oneiric, the machine became unbootable due to an incomplete /run migration. There's a bug in Launchpad, but it's not getting any attention.--
+   * breaks boot
+   * Maybe fixed in Precise
 
- # Unbootable machine: my home is dm-crypt encrypted, alghough not with luks. After upgrading to Oneiric, it was no longer being mounted because mount thought it was of type minixfs. WTF?? To fix this, I had to pass '-n nominix' to blkid in /lib/cryptsetup/checks/un_blkid. This filtering was present in an earlier version of cryptsetup, but it has been removed in 2:1.1.3-1.
+ # My home is dm-crypt encrypted, alghough not with luks. After upgrading to Oneiric, it was no longer being mounted because mount thought it was of type minixfs. WTF?? To fix this, I had to pass '-n nominix' to blkid in /lib/cryptsetup/checks/un_blkid. This filtering was present in an earlier version of cryptsetup, but it has been removed in 2:1.1.3-1.
+   * breaks boot
 
- # Unbootable machine: On my x200s, something goes wrong when initramfs tries to switch to the root filesystem. Due to a race with udev, some files cannot be deleted in the tmpfs.
+ # --On my x200s, something goes wrong when initramfs tries to switch to the root filesystem. Due to a race with udev, some files cannot be deleted in the tmpfs--
+   * breaks boot
    * https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/155689
    * https://bugs.launchpad.net/ubuntu/+source/linux/+bug/613273
    * FIXED: incomplete /run migration
 
- # Unbootable machine: Something was also broken with X and lightdm, but I have forgotten the details and how I fixed it.
+ # Apport no longer starts when something crashes in my unity session. It works for newly created users.
 
- # Apport no longer starts when something crashes in my unity session. It works for newly created users.
\ No newline at end of file
+ # --Tool tips have become black on black (hence, unreadable)--
+   * Confirmed on Precise
+   * https://bugs.launchpad.net/ubuntu/+source/gtk2-engines/+bug/144968
+   * I fixed this myself by editing sutff in dconf, but... wtf ubuntu!