Edit page UbuntuPaperCuts
authorbernie <bernie@74.94.156.211>
Sun, 13 May 2012 01:10:14 +0000 (21:10 -0400)
committerGeekiGeeki <webmaster@codewiz.org>
Sun, 13 May 2012 01:10:14 +0000 (21:10 -0400)
UbuntuPaperCuts

index e00cbf2..04707ad 100644 (file)
@@ -36,6 +36,7 @@
    * [[https://bugs.launchpad.net/ubuntu/+source/unity/+bug/803943]]: compiz consuming a lot of cpu
    * [[https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/888039]]: Gradual degradation in desktop performance.
    * [[https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/891744]]: Dragging windows stutter during and after grid animation
+   * Improved in Precise, but there's still high cpu usage in some cases (see bugs)
 
  # --When switching workspaces, focus can go to a window hidden behind another full-screen window. Compiz does not seem to remember which window previously had focus in each workspace.--
    * oneiric regression
@@ -64,8 +65,9 @@
 
 === Session management ===
 
- # confirmed on precise: There's no longer a way to save the X session? Before it was working only for some applications, but it was still a big time saver after a reboot.
+ # There's no longer a way to save the X session? Before it was working only for some applications, but it was still a big time saver after a reboot.
    * oneiric regression
+   * confirmed on precise
 
  # --Switch User Account locks my current session and then doesn't bring up the login screen. (I'm running gdm, not lightdm)--
    * oneiric regression
@@ -90,7 +92,6 @@
    * NOTABUG: works this way by design :-(
    * Workaround: uninstall notify-osd and install notification-daemon
 
-
  # --I can't configure the key to switch focus to the launcher to Super alone. I had to resort to Super-space, which is not comfortable for me--
    * fixed in oneiric
 
    * oneiric regression
    * Fixed in Precise
 
- # Evolution 3: the (webkit based) mail preview pane sometimes "crashes". It remains blank or garbled and there's no way to restore it until I restart the application.
-   * Confirmed on Precise
+ # --Evolution 3: the (webkit based) mail preview pane sometimes "crashes". It remains blank or garbled and there's no way to restore it until I restart the application.--
+   * Fixed in Precise
 
- # Evolution 3: forgets my Google account password every time I start it. Works with other IMAP accounts.
+ # --Evolution 3: forgets my Google account password every time I start it. Works with other IMAP accounts.--
+   * Fixed in Precise
 
- # Evolution 3: my Google calendars no longer show up (no errors are displayed). The CalDAV calendars still work.
+ # --Evolution 3: my Google calendars no longer show up (no errors are displayed). The CalDAV calendars still work.--
+   * Fixed in Precise
 
- # Evolution 3: sometimes Evolution just stops polling for email until I restart it
+ # --Evolution 3: sometimes Evolution just stops polling for email until I restart it--
+   * Fixed in Precise
 
- # Evolution 3: sometimes Evolution hangs during shutdown until I kill it from the terminal
+ # Evolution 3: sometimes Evolution hangs on shutdown until I kill it from the terminal
 
- # Evolution 3: this might sound like a rant, but due to many other stability issues with Evolution, my email experience has become really miserable in Oneiric.
+ # --Evolution 3: this might sound like a rant, but due to many other stability issues with Evolution, my email experience has become really miserable in Oneiric.--
+   * Decent in Precise
 
 
 === Hardware support ===
 
- # oneiric regression: When I connect a monitor to the DisplayPort output, sometimes the sound output also switches to it (but sometimes it doesn't, I couldn't figure out why). The sound output setting is buried deep into Control Panel / Sound Settings / Hardware / Profile, so it took me a while to figure out what had happened the first time.
+ # When I connect a monitor to the DisplayPort output, sometimes the sound output also switches to it (but sometimes it doesn't, I couldn't figure out why). The sound output setting is buried deep into Control Panel / Sound Settings / Hardware / Profile, so it took me a while to figure out what had happened the first time.
+   * oneiric regression
 
- # oneiric regression: HDMI/DisplayPort sound no longer works
+ # HDMI/DisplayPort sound no longer works
    * Probably this kernel 3.2 regression: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/973704
+   * Fixed in upstream kernel 3.4
 
  # If I unplug AC while the lid is closed, the laptop does not automatically suspend. This is very dangerous because you can accidentally store your laptop in a backpack while it's still running.
   * https://bugs.launchpad.net/ubuntu/+source/linux/+bug/886629
 
- # Wifi becomes incredibly slow after a few minutes of use (like, 1-2kb/s). This is a an Intel iwlagn 6250. I tried all kernels all the way to 3.2 with no improvement. The only workaround I could find is disabling 802.11n support.
+ # --Wifi becomes incredibly slow after a few minutes of use (like, 1-2kb/s). This is a an Intel iwlagn 6250. I tried all kernels all the way to 3.2 with no improvement. The only workaround I could find is disabling 802.11n support.--
    * Likely this bug: http://marc.info/?l=linux-kernel&m=131914553920614&w=2
+   * Fixed in precise
  
  # --My jWin Bluetooth headphones stop working when there's no sound output for about 30 seconds.  After this, all applications that try to play some sound will hang until I disconnect the bluetooth device--
    * Fixed in kernel 3.2
 
 === Upgrade issues ===
 
- # After upgrading to Oneiric, the machine became unbootable due to an incomplete /run migration. There's a bug in Launchpad, but it's not getting any attention.
+ # --After upgrading to Oneiric, the machine became unbootable due to an incomplete /run migration. There's a bug in Launchpad, but it's not getting any attention.--
    * breaks boot
+   * Maybe fixed in Precise
 
  # My home is dm-crypt encrypted, alghough not with luks. After upgrading to Oneiric, it was no longer being mounted because mount thought it was of type minixfs. WTF?? To fix this, I had to pass '-n nominix' to blkid in /lib/cryptsetup/checks/un_blkid. This filtering was present in an earlier version of cryptsetup, but it has been removed in 2:1.1.3-1.
    * breaks boot
 
  # Apport no longer starts when something crashes in my unity session. It works for newly created users.
 
- # Tool tips have become black on black (hence, unreadable)
+ # --Tool tips have become black on black (hence, unreadable)--
    * Confirmed on Precise
-   * https://bugs.launchpad.net/ubuntu/+source/gtk2-engines/+bug/144968
\ No newline at end of file
+   * https://bugs.launchpad.net/ubuntu/+source/gtk2-engines/+bug/144968
+   * I fixed this myself by editing sutff in dconf, but... wtf ubuntu!