Add attempt at rpm packaging.
[monkeysphere.git] / packaging / rpm / monkeysphere.spec
1 Name: monkeysphere
2 Summary: use the OpenPGP web of trust to verify ssh connections
3 Version: 0.22~pre
4 Release: 1
5 License: GPLv3
6 Group: net
7 URL: http://web.monkeysphere.info/
8
9 Source: http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_%{version}.orig.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11
12 BuildRequires: libgnutls-dev
13
14 %description
15 SSH key-based authentication is tried-and-true, but it lacks a true
16 Public Key Infrastructure for key certification, revocation and
17 expiration.  Monkeysphere is a framework that uses the OpenPGP web of
18 trust for these PKI functions.  It can be used in both directions: for
19 users to get validated host keys, and for hosts to authenticate users.
20
21 Monkeysphere is free software released under the GNU General Public
22 License (GPL).
23
24 %prep
25 %setup -q
26
27 %build
28 %configure --disable-debug
29 %{__make}
30
31 %install
32 %{__rm} -rf %{buildroot}
33 %makeinstall
34 %find_lang %{name}
35
36 %clean
37 %{__rm} -rf %{buildroot}
38
39 %files -f %{name}.lang
40 %defattr(-, root, root, 0755)
41 %doc AUTHORS ChangeLog INSTALL NEWS TODO README COPYING
42 %{_bindir}/monkeysphere
43 %{_datadir}/monkeysphere/
44
45 %changelog
46 * Sat Nov 22 2008 - 
47 - Initial release.