Improve RPM packaging
[monkeysphere.git] / packaging / rpm / monkeysphere.spec
1 Name: monkeysphere
2 Summary: Use the OpenPGP web of trust to verify ssh connections
3 Version: 0.29
4 Release: 1
5 License: GPLv3+
6 Group: Applications/Internet
7 URL: http://web.monkeysphere.info/
8
9 Source: http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_%{version}.orig.tar.gz
10
11 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13 Requires: gnupg
14 Requires: openssh-clients
15
16
17 %description
18 SSH key-based authentication is tried-and-true, but it lacks a true
19 Public Key Infrastructure for key certification, revocation and
20 expiration.  Monkeysphere is a framework that uses the OpenPGP web of
21 trust for these PKI functions.  It can be used in both directions: for
22 users to get validated host keys, and for hosts to authenticate users.
23
24 %prep
25 %setup -q
26
27 %build
28 %{__make} %{?_smp_mflags}
29
30 %install
31 %{__rm} -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33
34 %clean
35 %{__rm} -rf %{buildroot}
36
37 %files
38 %defattr(-, root, root, 0755)
39
40 %config(noreplace) %{_sysconfdir}/monkeysphere/monkeysphere-authentication.conf
41 %config(noreplace) %{_sysconfdir}/monkeysphere/monkeysphere-host.conf
42 %config(noreplace) %{_sysconfdir}/monkeysphere/monkeysphere.conf
43 %{_bindir}/monkeysphere
44 %{_bindir}/openpgp2ssh
45 %{_bindir}/pem2openpgp
46 %{_sbindir}/monkeysphere-authentication
47 %{_sbindir}/monkeysphere-host
48 %doc %{_docdir}/monkeysphere/Changelog
49 %doc %{_docdir}/monkeysphere/MonkeySpec
50 %doc %{_docdir}/monkeysphere/TODO
51 %doc %{_docdir}/monkeysphere/getting-started-admin.mdwn
52 %doc %{_docdir}/monkeysphere/getting-started-user.mdwn
53 %{_mandir}/man1/*
54 %{_mandir}/man7/*
55 %{_mandir}/man8/*
56 %{_datadir}/monkeysphere/*
57
58
59 %changelog
60 * Tue Mar 30 2010 Bernie Innocenti <bernie@codewiz.org> - 0.28
61 - Update to 0.28.
62 - Various fixes for Fedora.
63
64 * Sat Nov 22 2008 Anonymous Coward <anonymous@example.com> - 0.22
65 - Initial release.